1. #1

    Default Downloading troubles

    Ok so I set it to download the client last night--from the main website--to my linux setup. The next day I copied to my windows setup. When I booted up windows and tried to run the executable, it said it wasn't a win32 executable. My windows setup is WinXp Sp3. It meets all the minimum requireemnts with room, so what gives with that? Maybe somehow it got messed up when I saved it to my ubuntu partition, but that shouldn't happen. So today I went and downloaded from the main site. I noticed the bandwidth was only 300 kb/s. It seemed slow? So I tried downloading from the other link supplied by the accompanying techhaven site. I noticed it started fine but then dropped to 50 - 180 kb/s. Long story short, I made some mistakes and I got tired of downloading because it was steady 50-100 kb/s and taking forever.

    Anyone know what's going on. My DSL is able to download 1.1 MB/s or 11 to 12 maximum mbps.

  2. #2


    Download is back to 300 kb/s. Not sure if it's my end or somewhere else. I'll just be happy with that. Hopefully this download won't result in a "this is not a win32 executable." Does anybody use Ubuntu and know if it can "corrupt" an executable like that? I've never encountered it.

    Worth noting its icon was generic. Usually executable have a non-generic icon. Another thing is if it was a broken download then why wasn't there a *.part file or soemthing associated with it.
    Last edited by Arsco356; 12-02-17 at 10:19.

  3. #3
    Registered User
    Join Date
    October 2003
    Sheffield - England


    Hello mate.

    I'm assuming you've seen this article on runnig NC on linux https://wiki.techhaven.org/Running_Neocron_in_Linux

    I've been trying to get it working on a Chromebook, loaded with an Ubuntu derivative, and had no dice. Whether it plays or not on Linux appears to be something decided by the Gods

  4. #4


    The latest installer had some changes to overcome a few UAC issues on more recent versions of Windows. These fixes for UAC are unfortunately not compatible with Window XP so I'm afraid support for Windows XP is now at an end.

    Also there is a new launcher for Neocron in the works. This new launcher requires a minimum of Windows 7 SP1. I've updated the download page to reflect all these changes - my apologies for not doing this sooner.

    You also said download speeds are a bit varied - which country are you in and who is your ISP?
    Last edited by Bifrost; 13-02-17 at 00:50.
    Neocron Support Team
    N E O C R O N - G A M E . C O M

    »What's that coming over the hill? Is it a Warbot?«


  5. #5


    I'm in the US and my ISP is centurytel. Teh speeds went up late evening to 300 kb/s. Went down in the evening to 50-160. Normally speeds are fine but vary with the site.

    Sorry to hear about the xp thing, but I guess it's expected with an old OS, so I understand. Sometimes I get lucky though. Steam still runs at least and some others. I downloaded freeorion last night. Maybe will run and see what they updated over the version on my Ubuntu.

    I doubt I'll try it on Wine. I've had probelms wiht that. In general I don't trust it. Although Two Worlds (from Steam) runs real well. From what I understand all the programs I've run on Ubuntu--from GoG or Steam--use Wine. Baldur's Gate had too many bugs in Ubuntu so I ran in Windows. Trouble is it's very technical if it's not done for you. Most of the time I don't have the patience for that.
    Last edited by Arsco356; 12-02-17 at 21:40.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts